Universal DDI – DNS Record Recycle Bin Issue in (EU Region)

Incident Report for Infoblox

Resolved

This incident is resolved now.
Posted Apr 11, 2025 - 12:28 UTC

Monitoring

A fix has been applied, and we are monitoring the same.
Posted Apr 11, 2025 - 12:11 UTC

Investigating

We are experiencing an issue with Universal DDI in the EU Region, where customers may experience a delay with delete operations for DNS resource records. The newly deleted DNS records shall not be appearing in the Recycle Bin. Restore operation shall work fine.
Posted Apr 11, 2025 - 11:21 UTC
This incident affected: Universal DDI (Infoblox Portal - Europe).