[Operational Impact] Universal DDI Scheduled Maintenance

Scheduled for Apr 11, 02:30 UTC  -  Apr 13, 02:30 UTC

Update

In addition to the previously communicated maintenance impact, DTC services will also undergo updates during the maintenance window, resulting in brief interruptions of approximately 60 seconds.
Posted Apr 03, 2026 - 16:06 UTC

Scheduled

Universal DDI services in North America (https://portal.infoblox.com) and Europe (https://portal.eu.infoblox.com) will undergo scheduled maintenance starting April 11, 2026. During the maintenance, updates will be applied to the NIOS-X servers running DNS services. The update process will result in a DNS service interruption of approximately 60 seconds.

You can control the timing of these updates or defer them for up to 4 weeks using the 'Schedule Software Updates' feature in the Infoblox Portal.

Event Start Time: April 11, 2:30 AM UTC
Event End Time: April 13, 2:30 AM UTC
Posted Apr 03, 2026 - 12:17 UTC
This scheduled maintenance affects: Universal DDI (DNS - North America, DNS Traffic Control (DTC) - North America, DNS - Europe, DNS Traffic Control (DTC) - Europe).